Knowledgebase

 
 
Knowledgebase Article
Knowledgebase > Unified Communications > SmartNode > SmartWare


SmartNode 1K VPN using ISAKMP on Cisco ASA
Article Id #: 338

To enable SmartNode to connect using ISAKMP VPN to a Cisco ASA here is a template.

The goal of this configuration was to create a secure tunnel ( now only for voice ) via VPN.

Topology:

<SBC> - <Cisco ASA> - =VPN= -<SmartNode>

The network 10.100.1.1/32 is defined as a loopback because it is used only as an interface for Voice, however a small change ( having /24 and assign it to the LAN interface ) can make this setup useful also to provide secured network connectivity to the network.

SmartNode Configuration, please find the explanation after the important configuration lines, the network which is used: 10.100.1.1/24 ( in this config /32, as we use it only for VoIP ):

======================================================================================================================= 

profile acl VPNOut
permit 1 ah any any
permit 2 esp any any
permit 3 ip host 10.100.1.1 10.0.0.0 0.0.0.255 ipsec-policy VPN-IKE
permit 4 ip any any

profile acl VPNIn
permit 1 esp any any
permit 2 ah any any
permit 3 ip 10.0.0.0 0.0.0.31 host 10.100.1.1
permit 4 ip any any

profile ipsec-transform AES-256
esp-encryption 3des-cbc 192
esp-authentication hmac-md5-96
key-lifetime-seconds 86400
key-lifetime-kilobyte 4608000
# Usage of these lifetime parameters are recommended some Cisco webpage 


profile isakmp-transform AES-256
encryption aes-cbc 256
authentication-algorithm md5
key-lifetime-seconds 7200
# Usage of these lifetime parameters are recommended some Cisco webpage 


profile ipsec-policy-isakmp VPN-IKE
authentication-method pre-shared-key <PRE_SHARED_SECRET>
peer <CISCO_ASA_IP> interface <IP_INTERFACE_ON_SMARTNODE_TO_BE_USED>
# Specification of the local inetrface can be omitted, however can be recommended in some installations

mode tunnel
diffie-hellman-group group2
protected-network host 10.100.1.1 subnet 10.0.0.0 255.255.255.0 permanent-tunnel
# Usage of protected network is mandatory as this is going to be verified in the crypto access list
use profile ipsec-transform 1 AES-256

use profile isakmp-transform 1 AES-256

context ip

interface WAN
ipaddress <IP_ADDRESS> <NETMASK>
use profile acl VPNIn in
use profile acl VPNOut out
use profile napt NAPT_WAN
tcp adjust-mss rx mtu
tcp adjust-mss tx mtu
rtp-encryption
# Without enabling RTP encryption the RTP is not going to be transmitted, so there is no audio

interface IF_VPN
ipaddress 10.100.1.1 255.255.255.255
loopback
# Having a loopback ensures not to allow an external usage of the interface

tcp adjust-mss rx mtu
tcp adjust-mss tx mtu

context ip router
source-address-map 10.0.0.0 255.0.0.0 IF_VPN
# This is mandatory. Without this the SmartNode will use the IP address of the WAN port to generate local packets ( like ping, to test the connection )

context sip-gateway SIP_VPN

interface VVN
bind interface IF_VPN context router port 5060

context sip-gateway SIP_VPN
bind location-service LS_VVN
no shutdown

Cisco ASA Configuration:
=======================================================================================================================

access-list test1 extended permit ip 10.0.0.0 255.255.255.0 host 10.100.1.1
access-list remote_test1 extended permit ip host 10.100.1.1 10.0.0.0 255.255.255.0

crypto isakmp enable outside
crypto isakmp identity address

crypto map outside_map interface outside
crypto ipsec transform-set TestRule esp-3des esp-md5-hmac
crypto map outside_map 10 match address test1
crypto map outside_map 10 set peer <IP_ADDRESS_OF_THE_SMARTNODE>
crypto map outside_map 10 set transform-set Rule
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash md5
group 2
lifetime 3600

tunnel-group <IP_ADDRESS_OF_THE_SMARTNODE> type ipsec-l2l
tunnel-group <IP_ADDRESS_OF_THE_SMARTNODE> general-attributes
default-group-policy l2l_TestRule
tunnel-group <IP_ADDRESS_OF_THE_SMARTNODE> ipsec-attributes
pre-shared-key <PRE_SHARED_KEY>

group-policy l2l_TestRule internal
group-policy l2l_TestRule attributes

vpn-filter value remote_test1
vpn-tunnel-protocol IPSec 



User Rating
This answer was helpful This answer was not helpful (8780 vote(s)) 
User Comments  Add a Comment )

 
 
Products
Unified Communications
> VoIP Adapters
> Fax Adapters
> VoIP Gateways
> VoIP Routers
> VoIP IADs - Integrated Access Devices
> Enterprise Session Border Controllers
> Media Gateways
> SS7 Gateways
> Secure End Points (SIP Phones)
> VoIP Public Address & Mass Notification
Software and Cloud
> Virtual SBC | Virtualized SBC
> Virtual Access Router
> VPN Server
> IPv6 IPv4 Converter
> Intelligent Edge Orchestration
> NFV & SDN
Networking & Access
> Ethernet Extenders
> Industrial Switches
> Industrial Ethernet
> Unmanaged Industrial Ethernet Switches
> Managed Industrial Ethernet Switches
> Industrial PoE Switches
> PoE Extenders
> Industrial Network Solutions
> xDSL Products | DSL Modems, DSL VoIP, DSL Router Modems
> Routers
> Dial-Up Access

Sunset Products
 
Datacom Industrial Connectivity
> Industrial PoE Products
> Ethernet Over Fiber
> Line Drivers / Short Range Modems
> Wireline Analog Modems
> Pro AV Live & Media Broadcast Systems
> Fiber Serial DataCom (RS-232/422/530/188C)
> Fiber Telecom (T1/E1/PRI, Analog & ISDN)
> Multiplexers & Sharing Devices
> SFP (Small Form Pluggable) Modules and Kits
> Fiber Alarming, Notification, Relay & Control
> Other Network Extenders
> Defense/Security Fiber Communications
> Baluns
> Surge Protectors & Opto-Isolators
> DataTaps, Testers, Adapters, Rack Kits
> Interface Converters
> Fiber Rack & Enclosure Systems
> Fiber Repeaters & Wavelength Division Multiplexers (WDM)
> Waveguide RF Filters
Media Transport
> Artel Racks & Chassis Infrastructure
> Video Over IP Transport
> Video Over Fiber Transport
> Video, Audio & Data Over Fiber Transport
> Video & Audio Over Fiber Transport
> Ethernet Over Fiber Transport
> Serial DataComm Over Fiber Transport
> Video, Fiber Testers & Splitters
> Wave Division Multiplexers
> Ethernet Switches
> SFP Modules and Kits
 
Sales: [email protected] / +1 301 975 1000
Support: [email protected] / +1 301 975 1007
Join Our Email List
Have Us Contact You
or
Login Connect With Us
X Linkedin Facebook Youtube
 
     Patton LLC Copyright © 2022 All Rights Reserved.

|  Sitemap  |   Legal  |   Privacy Policy  |   Disclaimer  |    X  Facebook  YouTube  LinkedIn  RSS